use strict;
my $str = '"value" -> value
\'value\' -> value
"\\"value\\"" -> \\"value\\" <-- contains escaped quotes
"value\\" -> value\\"
"value\\\\" -> value\\\\ <-- contains escaped backslash before non-escaped quote
"""val"ue\\\\\\""" -> value\\\\\\"';
my $regex = qr/((?<!\\)(?:\\{2})*)["']/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";