#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)structure\s+([\w.-]+)\s*((?:(?!end\s+\1)[\s\S])*)end\s+\1"
Local $sString = "structure NAME_PART_1" & @CRLF & _
" Some content" & @CRLF & _
"" & @CRLF & _
" block NAME_PART_2" & @CRLF & _
" Some other content" & @CRLF & _
" end NAME_PART_2" & @CRLF & _
"" & @CRLF & _
" block NAME_PART_3" & @CRLF & _
" subblock NAME_PART_4" & @CRLF & _
" Some content++" & @CRLF & _
" end NAME_PART_4" & @CRLF & _
" end NAME_PART_3" & @CRLF & _
"" & @CRLF & _
"end NAME_PART_1" & @CRLF & _
"" & @CRLF & _
"structure " & @CRLF & _
" NAME_PART_5" & @CRLF & _
"" & @CRLF & _
"end NAME_PART_5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")