re = /structure\s+([\w.-]+)\s*((?:(?!end\s+\1)[\s\S])*)end\s+\1/m
str = 'structure NAME_PART_1
Some content
block NAME_PART_2
Some other content
end NAME_PART_2
block NAME_PART_3
subblock NAME_PART_4
Some content++
end NAME_PART_4
end NAME_PART_3
end NAME_PART_1
structure
NAME_PART_5
end NAME_PART_5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end