import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "structure\\s+([\\w.-]+)\\s*((?:(?!end\\s+\\1)[\\s\\S])*)end\\s+\\1";
final String string = "structure NAME_PART_1\n"
+ " Some content\n\n"
+ " block NAME_PART_2\n"
+ " Some other content\n"
+ " end NAME_PART_2\n\n"
+ " block NAME_PART_3\n"
+ " subblock NAME_PART_4\n"
+ " Some content++\n"
+ " end NAME_PART_4\n"
+ " end NAME_PART_3\n\n"
+ "end NAME_PART_1\n\n"
+ "structure \n"
+ " NAME_PART_5\n\n"
+ "end NAME_PART_5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}