using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"structure\s+([\w.-]+)\s*((?:(?!end\s+\1)[\s\S])*)end\s+\1";
string input = @"structure NAME_PART_1
Some content
block NAME_PART_2
Some other content
end NAME_PART_2
block NAME_PART_3
subblock NAME_PART_4
Some content++
end NAME_PART_4
end NAME_PART_3
end NAME_PART_1
structure
NAME_PART_5
end NAME_PART_5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}