import re
regex = re.compile(r"structure\s+([\w.-]+)\s*((?:(?!end\s+\1)[\s\S])*)end\s+\1", flags=re.MULTILINE)
test_str = ("structure NAME_PART_1\n"
" Some content\n\n"
" block NAME_PART_2\n"
" Some other content\n"
" end NAME_PART_2\n\n"
" block NAME_PART_3\n"
" subblock NAME_PART_4\n"
" Some content++\n"
" end NAME_PART_4\n"
" end NAME_PART_3\n\n"
"end NAME_PART_1\n\n"
"structure \n"
" NAME_PART_5\n\n"
"end NAME_PART_5")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")