const regex = /structure\s+([\w.-]+)\s*((?:(?!end\s+\1)[\s\S])*)end\s+\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('structure\\s+([\\w.-]+)\\s*((?:(?!end\\s+\\1)[\\s\\S])*)end\\s+\\1', 'gm')
const str = `structure NAME_PART_1
Some content
block NAME_PART_2
Some other content
end NAME_PART_2
block NAME_PART_3
subblock NAME_PART_4
Some content++
end NAME_PART_4
end NAME_PART_3
end NAME_PART_1
structure
NAME_PART_5
end NAME_PART_5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}