using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"value=""(?=<\?php)[^""]+""";
string substitution = @"";
string input = @"<html>
<h1>I poop <?php echo $whatHePoops; ?></h1>
</html>
<input type=""text"" class=""input input-1"" id=""CompanyName"" name=""CompanyName"" data-toggle=""tooltip"" data-placement=""top"" title=""Company Name/ Name of the Customer"" placeholder=""Company Name/ Name of the Customer"" value=""<?php echo $root['companyProfile']['customerCompanyName']; ?>"">";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}