re = /value="(?=<\?php)[^"]+"/
str = '<html>
<h1>I poop <?php echo $whatHePoops; ?></h1>
</html>
<input type="text" class="input input-1" id="CompanyName" name="CompanyName" data-toggle="tooltip" data-placement="top" title="Company Name/ Name of the Customer" placeholder="Company Name/ Name of the Customer" value="<?php echo $root[\'companyProfile\'][\'customerCompanyName\']; ?>">'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result