import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "value=\"(?=<\\?php)[^\"]+\"";
final String string = "<html>\n"
+ "<h1>I poop <?php echo $whatHePoops; ?></h1>\n"
+ "</html>\n\n"
+ "<input type=\"text\" class=\"input input-1\" id=\"CompanyName\" name=\"CompanyName\" data-toggle=\"tooltip\" data-placement=\"top\" title=\"Company Name/ Name of the Customer\" placeholder=\"Company Name/ Name of the Customer\" value=\"<?php echo $root['companyProfile']['customerCompanyName']; ?>\">";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}