const regex = /value="(?=<\?php)[^"]+"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('value="(?=<\\?php)[^"]+"', 'g')
const str = `<html>
<h1>I poop <?php echo \$whatHePoops; ?></h1>
</html>
<input type="text" class="input input-1" id="CompanyName" name="CompanyName" data-toggle="tooltip" data-placement="top" title="Company Name/ Name of the Customer" placeholder="Company Name/ Name of the Customer" value="<?php echo \$root['companyProfile']['customerCompanyName']; ?>">`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);