import re
regex = re.compile(r"value=\"(?=<\?php)[^\"]+\"")
test_str = ("<html>\n"
"<h1>I poop <?php echo $whatHePoops; ?></h1>\n"
"</html>\n\n"
"<input type=\"text\" class=\"input input-1\" id=\"CompanyName\" name=\"CompanyName\" data-toggle=\"tooltip\" data-placement=\"top\" title=\"Company Name/ Name of the Customer\" placeholder=\"Company Name/ Name of the Customer\" value=\"<?php echo $root['companyProfile']['customerCompanyName']; ?>\">")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)