#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Time in seconds =\s*([^\n]*)"
Local $sString = "Class = C" & @CRLF & _
"Size = 162x 162x 162" & @CRLF & _
"Iterations = 200" & @CRLF & _
"Time in seconds = 23.68" & @CRLF & _
"Total processes = 900" & @CRLF & _
"Compiled procs = 900" & @CRLF & _
"Mop/s total = 121032.40" & @CRLF & _
"Mop/s/process = 134.48"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")