package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Time in seconds =\s*([^\n]*)`)
var str = `Class = C
Size = 162x 162x 162
Iterations = 200
Time in seconds = 23.68
Total processes = 900
Compiled procs = 900
Mop/s total = 121032.40
Mop/s/process = 134.48`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}