const regex = /Time in seconds =\s*([^\n]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Time in seconds =\\s*([^\\n]*)', 'gm')
const str = `Class = C
Size = 162x 162x 162
Iterations = 200
Time in seconds = 23.68
Total processes = 900
Compiled procs = 900
Mop/s total = 121032.40
Mop/s/process = 134.48`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}