re = /Time in seconds =\s*([^\n]*)/m
str = 'Class = C
Size = 162x 162x 162
Iterations = 200
Time in seconds = 23.68
Total processes = 900
Compiled procs = 900
Mop/s total = 121032.40
Mop/s/process = 134.48'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end