import re
regex = re.compile(r"Time in seconds =\s*([^\n]*)", flags=re.MULTILINE)
test_str = ("Class = C\n"
"Size = 162x 162x 162\n"
"Iterations = 200\n"
"Time in seconds = 23.68\n"
"Total processes = 900\n"
"Compiled procs = 900\n"
"Mop/s total = 121032.40\n"
"Mop/s/process = 134.48")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")