import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Time in seconds =\\s*([^\\n]*)";
final String string = "Class = C\n"
+ "Size = 162x 162x 162\n"
+ "Iterations = 200\n"
+ "Time in seconds = 23.68\n"
+ "Total processes = 900\n"
+ "Compiled procs = 900\n"
+ "Mop/s total = 121032.40\n"
+ "Mop/s/process = 134.48";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}