package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d{2,3}|\d{1,3}(?:,\d{3})+)(?:,\d{3})+$`)
var str = `10,400,000
10,900,000
500,000
10,000
100,000
1,000,000
10,000,000
100,000,000
1,000,000,000
1
1,0
10
100
1,000
10,00
10000
100,00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}