use strict;
my $str = '10,400,000
10,900,000
500,000
10,000
100,000
1,000,000
10,000,000
100,000,000
1,000,000,000
1
1,0
10
100
1,000
10,00
10000
100,00';
my $regex = qr`^(?:\d{2,3}|\d{1,3}(?:,\d{3})+)(?:,\d{3})+$`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}