const regex = new RegExp('^(?:\\d{2,3}|\\d{1,3}(?:,\\d{3})+)(?:,\\d{3})+$', 'gm')
const str = `10,400,000
10,900,000
500,000
10,000
100,000
1,000,000
10,000,000
100,000,000
1,000,000,000
1
1,0
10
100
1,000
10,00
10000
100,00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}