re = /^(?:\d{2,3}|\d{1,3}(?:,\d{3})+)(?:,\d{3})+$/m
str = '10,400,000
10,900,000
500,000
10,000
100,000
1,000,000
10,000,000
100,000,000
1,000,000,000
1
1,0
10
100
1,000
10,00
10000
100,00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end