import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{2,3}|\\d{1,3}(?:,\\d{3})+)(?:,\\d{3})+$";
final String string = "10,400,000\n"
+ "10,900,000\n"
+ "500,000\n\n"
+ "10,000\n"
+ "100,000\n"
+ "1,000,000\n"
+ "10,000,000\n"
+ "100,000,000\n"
+ "1,000,000,000\n\n"
+ "1\n"
+ "1,0\n"
+ "10\n"
+ "100\n"
+ "1,000\n"
+ "10,00\n"
+ "10000\n"
+ "100,00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}