// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d{2,3}|\d{1,3}(?:,\d{3})+)(?:,\d{3})+$").unwrap();
let string = "10,400,000
10,900,000
500,000
10,000
100,000
1,000,000
10,000,000
100,000,000
1,000,000,000
1
1,0
10
100
1,000
10,00
10000
100,00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}