#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d{3})(?=\d{2})|(?<=\d{2})(?=\d{2}$)"
Local $sString = "0555370002654"
Local $sSubst = "\1-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)