import Foundation
let pattern = #"(\d{3})(?=\d{2})|(?<=\d{2})(?=\d{2}$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"0555370002654"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)