$re = '/(\d{3})(?=\d{2})|(?<=\d{2})(?=\d{2}$)/m';
$str = '0555370002654';
$subst = "\1-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;