using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{3})(?=\d{2})|(?<=\d{2})(?=\d{2}$)";
string substitution = @"\1-";
string input = @"0555370002654";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}