re = /(\d{3})(?=\d{2})|(?<=\d{2})(?=\d{2}$)/m
str = '0555370002654'
subst = '\\1-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result