const regex = new RegExp('(\\d{3})(?=\\d{2})|(?<=\\d{2})(?=\\d{2}$)', 'gm')
const str = `0555370002654`;
const subst = `\1-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);