use strict;
my $str = '0555370002654';
my $regex = qr/(\d{3})(?=\d{2})|(?<=\d{2})(?=\d{2}$)/mp;
my $subst = '\\1-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";