use strict;
my $str = '25FGl34Mcoas (2)
56FttM335Loas
11ShaT44 (3)';
my $regex = qr/^([^()]+)$/mp;
my $subst = '\\L$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";