#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i).*<br>Name:(.*)\s<br>|[^(mailto:)>|+][a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+|:\s(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})"
Local $sString = "<br><br>Name:Adı Soyadı <br>\r\n ◀" & @CRLF & _
"E-Mail: <a href="mailto:1denememail@hotmail.com" target="_blank">1denememail@hotmail.com</a> <br>\r\n" & @CRLF & _
"Hash: 12234343242342344, 00000, AC:TRUE IP: 127.0.0.1" & @CRLF & _
"This regex was created by ~~Barış Yılmaz~~" & @CRLF & _
"asdf" & @CRLF & _
"asadasdasd" & @CRLF & _
"asdasdasdf" & @CRLF & _
"<br>" & @CRLF & _
"https://wmaraci.com/forum/" & @CRLF & _
"<br>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")