$re = '/(?i).*<br>Name:(.*)\s<br>|[^(mailto:)>|+][a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+|:\s(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})/m';
$str = '<br><br>Name:Adı Soyadı <br>\\r\\n ◀
E-Mail: <a href="mailto:1denememail@hotmail.com" target="_blank">1denememail@hotmail.com</a> <br>\\r\\n
Hash: 12234343242342344, 00000, AC:TRUE IP: 127.0.0.1
This regex was created by ~~Barış Yılmaz~~
asdf
asadasdasd
asdasdasdf
<br>
https://wmaraci.com/forum/
<br>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);