import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i).*<br>Name:(.*)\\s<br>|[^(mailto:)>|+][a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\\.[a-zA-Z0-9-.]+|:\\s(\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})";
final String string = "<br><br>Name:Adı Soyadı <br>\\r\\n ◀\n"
+ "E-Mail: <a href=\"mailto:1denememail@hotmail.com\" target=\"_blank\">1denememail@hotmail.com</a> <br>\\r\\n\n"
+ "Hash: 12234343242342344, 00000, AC:TRUE IP: 127.0.0.1\n"
+ "This regex was created by ~~Barış Yılmaz~~\n"
+ "asdf\n"
+ "asadasdasd\n"
+ "asdasdasdf\n"
+ "<br>\n"
+ "https://wmaraci.com/forum/\n"
+ "<br>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}