import re
regex = re.compile(r"(?i).*<br>Name:(.*)\s<br>|[^(mailto:)>|+][a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+|:\s(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})", flags=re.MULTILINE)
test_str = ("<br><br>Name:Adı Soyadı <br>\\r\\n ◀\n"
"E-Mail: <a href=\"mailto:1denememail@hotmail.com\" target=\"_blank\">1denememail@hotmail.com</a> <br>\\r\\n\n"
"Hash: 12234343242342344, 00000, AC:TRUE IP: 127.0.0.1\n"
"This regex was created by ~~Barış Yılmaz~~\n"
"asdf\n"
"asadasdasd\n"
"asdasdasdf\n"
"<br>\n"
"https://wmaraci.com/forum/\n"
"<br>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")