use strict;
my $str = '<br><br>Name:Adı Soyadı <br>\\r\\n ◀
E-Mail: <a href="mailto:1denememail@hotmail.com" target="_blank">1denememail@hotmail.com</a> <br>\\r\\n
Hash: 12234343242342344, 00000, AC:TRUE IP: 127.0.0.1
This regex was created by ~~Barış Yılmaz~~
asdf
asadasdasd
asdasdasdf
<br>
https://wmaraci.com/forum/
<br>';
my $regex = qr/(?i).*<br>Name:(.*)\s<br>|[^(mailto:)>|+][a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+|:\s(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}