// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i).*<br>Name:(.*)\s<br>|[^(mailto:)>|+][a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+|:\s(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})").unwrap();
let string = "<br><br>Name:Adı Soyadı <br>\\r\\n ◀
E-Mail: <a href=\"mailto:1denememail@hotmail.com\" target=\"_blank\">1denememail@hotmail.com</a> <br>\\r\\n
Hash: 12234343242342344, 00000, AC:TRUE IP: 127.0.0.1
This regex was created by ~~Barış Yılmaz~~
asdf
asadasdasd
asdasdasdf
<br>
https://wmaraci.com/forum/
<br>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}