#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sU)<xf:if is="\$post\.edit_count && \$post\.canViewHistory\(\)".*</xf:if>"
Local $sString = "<xf:if is="$post.edit_count && $post.canViewHistory()">" & @CRLF & _
" <a href="{{ link('posts/history', $post) }}"" & @CRLF & _
" class="actionBar-action actionBar-action--history actionBar-action--menuItem"" & @CRLF & _
" data-xf-click="toggle"" & @CRLF & _
" data-target="#js-post-{$post.post_id} .js-historyTarget"" & @CRLF & _
" data-menu-closer="true">{{ phrase('history') }}</a>" & @CRLF & _
"" & @CRLF & _
" <xf:set var="$hasActionBarMenu" value="{{ true }}" />" & @CRLF & _
" </xf:if><xf:if is="$foo">foo</xf:if>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")