using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<xf:if is=""\$post\.edit_count && \$post\.canViewHistory\(\)"".*</xf:if>";
string input = @"<xf:if is=""$post.edit_count && $post.canViewHistory()"">
<a href=""{{ link('posts/history', $post) }}""
class=""actionBar-action actionBar-action--history actionBar-action--menuItem""
data-xf-click=""toggle""
data-target=""#js-post-{$post.post_id} .js-historyTarget""
data-menu-closer=""true"">{{ phrase('history') }}</a>
<xf:set var=""$hasActionBarMenu"" value=""{{ true }}"" />
</xf:if><xf:if is=""$foo"">foo</xf:if>";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}