import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<xf:if is=\"\\$post\\.edit_count && \\$post\\.canViewHistory\\(\\)\".*</xf:if>";
final String string = "<xf:if is=\"$post.edit_count && $post.canViewHistory()\">\n"
+ " <a href=\"{{ link('posts/history', $post) }}\"\n"
+ " class=\"actionBar-action actionBar-action--history actionBar-action--menuItem\"\n"
+ " data-xf-click=\"toggle\"\n"
+ " data-target=\"#js-post-{$post.post_id} .js-historyTarget\"\n"
+ " data-menu-closer=\"true\">{{ phrase('history') }}</a>\n\n"
+ " <xf:set var=\"$hasActionBarMenu\" value=\"{{ true }}\" />\n"
+ " </xf:if><xf:if is=\"$foo\">foo</xf:if>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}