import re
regex = re.compile(r"<xf:if is=\"\$post\.edit_count && \$post\.canViewHistory\(\)\".*</xf:if>", flags=re.DOTALL)
test_str = ("<xf:if is=\"$post.edit_count && $post.canViewHistory()\">\n"
" <a href=\"{{ link('posts/history', $post) }}\"\n"
" class=\"actionBar-action actionBar-action--history actionBar-action--menuItem\"\n"
" data-xf-click=\"toggle\"\n"
" data-target=\"#js-post-{$post.post_id} .js-historyTarget\"\n"
" data-menu-closer=\"true\">{{ phrase('history') }}</a>\n\n"
" <xf:set var=\"$hasActionBarMenu\" value=\"{{ true }}\" />\n"
" </xf:if><xf:if is=\"$foo\">foo</xf:if>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")