// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?sU)<xf:if is="\$post\.edit_count && \$post\.canViewHistory\(\)".*</xf:if>"#).unwrap();
let string = "<xf:if is=\"$post.edit_count && $post.canViewHistory()\">
<a href=\"{{ link('posts/history', $post) }}\"
class=\"actionBar-action actionBar-action--history actionBar-action--menuItem\"
data-xf-click=\"toggle\"
data-target=\"#js-post-{$post.post_id} .js-historyTarget\"
data-menu-closer=\"true\">{{ phrase('history') }}</a>
<xf:set var=\"$hasActionBarMenu\" value=\"{{ true }}\" />
</xf:if><xf:if is=\"$foo\">foo</xf:if>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}