use strict;
my $str = '<xf:if is="$post.edit_count && $post.canViewHistory()">
<a href="{{ link(\'posts/history\', $post) }}"
class="actionBar-action actionBar-action--history actionBar-action--menuItem"
data-xf-click="toggle"
data-target="#js-post-{$post.post_id} .js-historyTarget"
data-menu-closer="true">{{ phrase(\'history\') }}</a>
<xf:set var="$hasActionBarMenu" value="{{ true }}" />
</xf:if><xf:if is="$foo">foo</xf:if>';
my $regex = qr%<xf:if is="\$post\.edit_count && \$post\.canViewHistory\(\)".*</xf:if>%sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}