re = /<xf:if is="\$post\.edit_count && \$post\.canViewHistory\(\)".*<\/xf:if>/
str = '<xf:if is="$post.edit_count && $post.canViewHistory()">
<a href="{{ link(\'posts/history\', $post) }}"
class="actionBar-action actionBar-action--history actionBar-action--menuItem"
data-xf-click="toggle"
data-target="#js-post-{$post.post_id} .js-historyTarget"
data-menu-closer="true">{{ phrase(\'history\') }}</a>
<xf:set var="$hasActionBarMenu" value="{{ true }}" />
</xf:if><xf:if is="$foo">foo</xf:if>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end