# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)^[AB][ ]([0-9]{3})$/'C [a-z]*$1'/g;t' <<< "A 123
B 323"