using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^[AB][ ]([0-9]{3})$";
string substitution = @"'C [a-z]*$1'";
string input = @"A 123
B 323";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}