use strict;
my $str = 'A 123
B 323';
my $regex = qr/(?m)^[AB][ ]([0-9]{3})$/p;
my $subst = '\'C [a-z]*$1\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";