package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[AB][ ]([0-9]{3})$`)
var str = `A 123
B 323`
var substitution = "'C [a-z]*$1'"
fmt.Println(re.ReplaceAllString(str, substitution))
}