#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[AB][ ]([0-9]{3})$"
Local $sString = "A 123" & @CRLF & _
"B 323"
Local $sSubst = "'C [a-z]*$1'"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)